Switch Directory not working in new portal

Admin FD
New Contributor

We have created 4 directories within our Azure AD environment.

I can see all 4 directories in the old Windows Azure portal. But I'm not able to see them when I press "Switch Directory" in the new Portal.


Check attached screenshot. In both portals I have logged on with the same account. Tried multiple browsers and cleared cached.



4 Replies

Hm, I have no problem here, try a Private session just in case. If it still doesn't work, open a support case.

I have not had problems either when switching directories in the new works quite well in my experience

From this day on, you can't use the old portal anymore to manage your AAD.

So I just tried some in-private windows again. Without any luck.


Then I pressed the "Restore Default settings" under "Portal Settings". And that seems to have fixed it for me. Now it works again in all the different browsers. Hopefully it keeps working for me as well!

Open up

Click on Azure Active Directory

You will now see your default directory

On the right hand side you will now see the switch directory option

Attaching a screenshot

Related Conversations
Switch Directory not working in new portal
Admin FD in Azure Active Directory on
4 Replies
Microsoft Teams switch account
Prabhakar Sastry in Microsoft Teams on
11 Replies