Home

AzureAD sharepoint SAML integrattion

%3CLINGO-SUB%20id%3D%22lingo-sub-306753%22%20slang%3D%22en-US%22%3EAzureAD%20sharepoint%20SAML%20integrattion%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-306753%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20trying%20to%20federate%20salesforce%20to%20use%20AzureAD%20for%20authentication.%20I%20did%20some%20testing%20in%20a%20sandpit%20in%20salesforce.%20Did%20all%20the%20configuration%20and%20it%20all%20works%20when%20i%20use%20the%20microsoft%20account%20i.e%20a%20trial%20account%20in%20azure.%20However%2C%20when%20I%20create%20a%20new%20user%20in%20Azure%20AD%20and%20try%20and%20login%20as%20that%20user%20in%20salesforce%2C%20I%20keep%20getting%20a%20SAML%20error.%20I%20do%20get%20redirected%20to%20login.microsoft%20webpage%20for%20auth%20but%20the%20moment%20i%20enter%20the%20credentials%20of%20the%20user%20it%20doesnt%20work.%20I%20used%20the%20email-id%20as%20federation-id%20so%20if%20the%20user.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20I%20have%20gathered%20is%20that%20when%20the%20federation%20works%20when%20I%20use%20the%20MS%20account%20but%20not%20as%20a%20user%20in%20AAD.%26nbsp%3B%20Can%20someone%20please%20explain%20the%20reason%20behind%20this%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3EAR%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-306753%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20AD%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-313233%22%20slang%3D%22en-US%22%3ERe%3A%20AzureAD%20sharepoint%20SAML%20integrattion%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-313233%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESorry%20for%20the%20delay.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFirstly%2C%20I%20recommend%20making%20sure%20the%20following%20attributes%20match.%20This%20reduces%20administrative%20overhead%20and%20provides%20the%20best%20user%20experience.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CTABLE%3E%3CTBODY%3E%3CTR%3E%3CTD%3E%3CP%3ESetting%3C%2FP%3E%3C%2FTD%3E%3CTD%3E%3CP%3EAzure%20AD%20Attribute%20Name%3C%2FP%3E%3C%2FTD%3E%3C%2FTR%3E%3CTR%3E%3CTD%3E%3CP%3ESIP%3C%2FP%3E%3C%2FTD%3E%3CTD%3E%3CP%3EProxyAddresses%20%E2%80%93%20denoted%20with%20a%20prefix%20of%20uppercase%20%E2%80%98SMTP%E2%80%99%3C%2FP%3E%3C%2FTD%3E%3C%2FTR%3E%3CTR%3E%3CTD%3E%3CP%3EPrimary%20SMTP%20(default%20send%20from%20address)%3C%2FP%3E%3C%2FTD%3E%3CTD%3E%3CP%3EProxyAddresses%20%E2%80%93%20denoted%20a%20prefix%20%E2%80%98SIP%E2%80%99%3C%2FP%3E%3C%2FTD%3E%3C%2FTR%3E%3CTR%3E%3CTD%3E%3CP%3EMail%3C%2FP%3E%3C%2FTD%3E%3CTD%3E%3CP%3EWindowsEmailAddress%20(Exchange)%2C%20Mail%20(Graph%20API)%3C%2FP%3E%3C%2FTD%3E%3C%2FTR%3E%3CTR%3E%3CTD%3E%3CP%3EUser%20Principal%20Name%20(AzureAD%20login%20name)%3C%2FP%3E%3C%2FTD%3E%3CTD%3E%3CP%3EUserPrincipalName%3C%2FP%3E%3C%2FTD%3E%3C%2FTR%3E%3CTR%3E%3CTD%3E%3CP%3EAlternative%20ID%20(**avoid%20if%20possible)%3C%2FP%3E%3C%2FTD%3E%3CTD%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FTD%3E%3C%2FTR%3E%3C%2FTBODY%3E%3C%2FTABLE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E**%20I%20hear%20you%20On-prem%20Active%20Directory%20admins%2C%20yes%2C%20it%E2%80%99s%20a%20lot%20of%20work%20but%20these%20changes%20%3CU%3Ewill%3C%2FU%3E%20save%20you%20a%20world%20of%20pain%20%3Asmiling_face_with_smiling_eyes%3A%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWith%20reference%20to%20your%20problem%2C%20the%20mail%20attribute%20%E2%80%9Cuser.mail%E2%80%9D%2C%20isn%E2%80%99t%20used%20by%20Exchange%20or%20sending%20email%2C%20and%20is%20often%20out%20of%20date%20or%20not%20set%20at%20all.%20Now%20in%20saying%20that%2C%20Azure%20AD%20has%20some%20interesting%20rules%20which%20in%20some%20cases%20populate%20the%20mail%20attribute%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-gb%2Fhelp%2F3190357%2Fhow-the-proxyaddresses-attribute-is-populated-in-azure-ad%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.microsoft.com%2Fen-gb%2Fhelp%2F3190357%2Fhow-the-proxyaddresses-attribute-is-populated-in-azure-ad%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EPersonally%2C%20I%20wouldn%E2%80%99t%20rely%20on%20Azure%20AD%26nbsp%3Bupdating%20synchronised%20accounts.%20%3C%2FSTRONG%3EPlease%3CSTRONG%3E%20m%3C%2FSTRONG%3Eanage%20the%20mail%20attribute%20using%20On-Prem%20AD%20to%20avoid%20ambiguity.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20how%20does%20this%20help%20me%3F%20%3Asmiling_face_with_smiling_eyes%3A%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheck%20one%20of%20your%20problematic%20users%20using%20the%20Graph%20API%20explorer%2C%20unless%20you%20connect%20to%20Exchange%20Online%2C%20mail%20attribute%20isn't%20exposed%3A%3C%2FP%3E%3COL%3E%3CLI%3ELogin%20to%20the%20graph%20api%20explorer%20-%20%3CA%20href%3D%22https%3A%2F%2Fdeveloper.microsoft.com%2Fen-us%2Fgraph%2Fgraph-explorer%23%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdeveloper.microsoft.com%2Fen-us%2Fgraph%2Fgraph-explorer%23%3C%2FA%3E%3C%2FLI%3E%3CLI%3EPaste%20the%20following%20query%20into%20the%20query%20window%20and%20add%20you%20users%20UPN%3C%2FLI%3E%3CLI%3E%3CA%20href%3D%22https%3A%2F%2Fgraph.microsoft.com%2Fv1.0%2Fusers%2F%255bUPNHere%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgraph.microsoft.com%2Fv1.0%2Fusers%2F%5BUPNHere%3C%2FA%3E%5D%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F65779iCB752C98AC3A707E%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22AD.png%22%20title%3D%22AD.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FLI%3E%3C%2FOL%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-313156%22%20slang%3D%22en-US%22%3ERe%3A%20AzureAD%20sharepoint%20SAML%20integrattion%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-313156%22%20slang%3D%22en-US%22%3E%3CP%3EHave%20you%20tried%20user.userprincipalname%20as%20suggested%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-310143%22%20slang%3D%22en-US%22%3ERe%3A%20AzureAD%20sharepoint%20SAML%20integrattion%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-310143%22%20slang%3D%22en-US%22%3Ehi%20thinksync%2C%3CBR%20%2F%3E%3CBR%20%2F%3Eany%20ideas%3F%3CBR%20%2F%3E%3CBR%20%2F%3ERegards%3CBR%20%2F%3EAR%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-309532%22%20slang%3D%22en-US%22%3ERe%3A%20AzureAD%20sharepoint%20SAML%20integrattion%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-309532%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20ThinkSync%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThey%20are%20correctly%20set%20to%20user.mail.%26nbsp%3B%20The%20thing%20that%20I%20am%20stuck%20is%20that%20it%20works%20for%20the%20microsoft%20account%20i.e%20the%20account%20I%20login%20to%20the%20azure%20tenant%20with.%20However%2C%20it%20doesn't%20work%20with%20users%20that%20are%20in%20the%20AAD.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%26nbsp%3B%3C%2FP%3E%3CP%3EAR%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-309510%22%20slang%3D%22en-US%22%3ERe%3A%20AzureAD%20sharepoint%20SAML%20integrattion%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-309510%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPlease%20check%20your%20Saleforce%20claim%20mappings%2C%20nameidentifier%20should%20map%20to%20user.mail%20or%20user.userprincipalname.%20These%20values%20should%20be%20identical%20to%20the%20Saleforce%20account%20FederationID.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20you%E2%80%99re%20using%20user.mail%2C%20please%20check%20the%20accounts%20have%20the%20mail%20attribute%20using%20the%20Azure%20AD%20PowerShell%20cmdlets%20for%20cloud%20accounts%20or%20sync'd%2C%26nbsp%3BActive%20Directory%20Users%20and%20Computers.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F64786iFB138DF83B891B5E%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%221.png%22%20title%3D%221.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20841px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F64787i2BC6AC0D3DA4C2A4%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%222.png%22%20title%3D%222.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CEM%3EIf%20you%E2%80%99ve%20found%20this%20post%20helpful%2C%20please%20click%20the%26nbsp%3B%3CSTRONG%3ELike%3C%2FSTRONG%3E%26nbsp%3Bbutton.%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-309493%22%20slang%3D%22en-US%22%3ERe%3A%20AzureAD%20sharepoint%20SAML%20integrattion%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-309493%22%20slang%3D%22en-US%22%3E%3CP%3Ehi%20Peter%20%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHappy%20new%20year%20and%20apologies%20for%20the%20delay%20in%20responding.%3C%2FP%3E%3CP%3Ethanks%20for%20your%20email.%20Below%20is%20what%20i%20have%20found%20in%20the%20trace.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3ESAMLtrace%20for%20working%20user%20which%20is%20a%20microsoft%20online%20account%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CNAMEID%20format%3D%22%26quot%3Burn%3Aoasis%3Anames%3Atc%3ASAML%3A1.1%3Anameid-format%3AemailAddress%26quot%3B%22%3Emaverick1%40hotmail.com%3C%2FNAMEID%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eyou%20can%20see%20that%20azure%20is%20passing%20the%20email%20address%20which%20is%20used%20as%20federatedID%20between%20azure%20and%20salesforce%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3ESAMLtrace%20for%20non-working%20user%20which%20is%20a%20user%20account%20in%20the%20directory%26nbsp%3B%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%3CNAMEID%20format%3D%22%26quot%3Burn%3Aoasis%3Anames%3Atc%3ASAML%3A2.0%3Anameid-format%3Apersistent%26quot%3B%22%3EF8xKa2JIpxTCFjO66gjj-9TrfpXfOnyxOHogR8s1PA4%3C%2FNAMEID%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAs%26nbsp%3B%20you%20can%20see%20from%20above%20that%20the%20email%20address%20is%20not%20being%20passed%20as%20federationID%20for%20the%20user%20in%20the%20directory%20.%20So%20%2C%20it%20only%20seems%20to%20work%20with%20the%20MS%20online%20account.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eyour%20help%20would%20be%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-306971%22%20slang%3D%22en-US%22%3ERe%3A%20AzureAD%20sharepoint%20SAML%20integrattion%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-306971%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESaleforce%20integration%20can%20be%20tricky%2C%20have%20you%20checked%20the%20following%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EYou%20have%20licensed%20Saleforce%20accounts%20that%20correspond%20to%20your%20Azure%20AD%20accounts%20-%20%22shadow%20accounts%22%20that%20sit%20in%20the%20Salesforce%20iDP.%3C%2FLI%3E%3CLI%3EThe%20Salesforce%20accounts%20FederationIdentifier%20matches%20your%20Azure%20AD%20accounts%20UserPrincipalName.%3C%2FLI%3E%3CLI%3EIf%20you%20haven%E2%80%99t%20setup%20account%20provisioning%20referenced%20above%2C%20please%20follow%20the%20following%20tutorial%3C%2FLI%3E%3C%2FOL%3E%3CP%3E%3CSTRONG%3EConfigure%20Salesforce%20for%20automatic%20user%20provisioning%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fsaas-apps%2Fsalesforce-provisioning-tutorial%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fsaas-apps%2Fsalesforce-provisioning-tutorial%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20this%20helps!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F64267i5DF7FEBFC1A5700B%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Salesforce.png%22%20title%3D%22Salesforce.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-306806%22%20slang%3D%22en-US%22%3ERe%3A%20AzureAD%20sharepoint%20SAML%20integrattion%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-306806%22%20slang%3D%22en-US%22%3E%3CP%3EWhat%20is%20the%20SAML%20error%2C%20can%20it%20not%20find%20the%20user%3F%26nbsp%3B%20Can%20you%20post%20the%20SAML%20trace%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
AzureRanger
New Contributor

Hi All,

 

We are trying to federate salesforce to use AzureAD for authentication. I did some testing in a sandpit in salesforce. Did all the configuration and it all works when i use the microsoft account i.e a trial account in azure. However, when I create a new user in Azure AD and try and login as that user in salesforce, I keep getting a SAML error. I do get redirected to login.microsoft webpage for auth but the moment i enter the credentials of the user it doesnt work. I used the email-id as federation-id so if the user.

 

What I have gathered is that when the federation works when I use the MS account but not as a user in AAD.  Can someone please explain the reason behind this?

 

Regards,

AR

8 Replies

What is the SAML error, can it not find the user?  Can you post the SAML trace?

 

Hello,

 

Saleforce integration can be tricky, have you checked the following?

 

  1. You have licensed Saleforce accounts that correspond to your Azure AD accounts - "shadow accounts" that sit in the Salesforce iDP.
  2. The Salesforce accounts FederationIdentifier matches your Azure AD accounts UserPrincipalName.
  3. If you haven’t setup account provisioning referenced above, please follow the following tutorial

Configure Salesforce for automatic user provisioning

https://docs.microsoft.com/en-us/azure/active-directory/saas-apps/salesforce-provisioning-tutorial

 

Hope this helps!

 

 

 Salesforce.png

hi Peter ,

 

Happy new year and apologies for the delay in responding.

thanks for your email. Below is what i have found in the trace.

 

SAMLtrace for working user which is a microsoft online account

 

<NameID Format="urn:oasis:names:tc:SAML:1.1:nameid-format:emailAddress">maverick1@hotmail.com</NameID>

 

you can see that azure is passing the email address which is used as federatedID between azure and salesforce

 

SAMLtrace for non-working user which is a user account in the directory 

<NameID Format="urn:oasis:names:tc:SAML:2.0:nameid-format:persistent">F8xKa2JIpxTCFjO66gjj-9TrfpXfOnyxOHogR8s1PA4</NameID>

 

As  you can see from above that the email address is not being passed as federationID for the user in the directory . So , it only seems to work with the MS online account.

 

your help would be appreciated.

Hello,

 

Please check your Saleforce claim mappings, nameidentifier should map to user.mail or user.userprincipalname. These values should be identical to the Saleforce account FederationID.

 

If you’re using user.mail, please check the accounts have the mail attribute using the Azure AD PowerShell cmdlets for cloud accounts or sync'd, Active Directory Users and Computers.

1.png

2.png

If you’ve found this post helpful, please click the Like button.

Hi ThinkSync,

 

They are correctly set to user.mail.  The thing that I am stuck is that it works for the microsoft account i.e the account I login to the azure tenant with. However, it doesn't work with users that are in the AAD.

 

 

Thanks 

AR

hi thinksync,

any ideas?

Regards
AR

Have you tried user.userprincipalname as suggested?

Hello,

 

Sorry for the delay.

 

Firstly, I recommend making sure the following attributes match. This reduces administrative overhead and provides the best user experience.

 

Setting

Azure AD Attribute Name

SIP

ProxyAddresses – denoted with a prefix of uppercase ‘SMTP’

Primary SMTP (default send from address)

ProxyAddresses – denoted a prefix ‘SIP’

Mail

WindowsEmailAddress (Exchange), Mail (Graph API)

User Principal Name (AzureAD login name)

UserPrincipalName

Alternative ID (**avoid if possible)

 

 

** I hear you On-prem Active Directory admins, yes, it’s a lot of work but these changes will save you a world of pain :smiling_face_with_smiling_eyes:

 

With reference to your problem, the mail attribute “user.mail”, isn’t used by Exchange or sending email, and is often out of date or not set at all. Now in saying that, Azure AD has some interesting rules which in some cases populate the mail attribute:

https://support.microsoft.com/en-gb/help/3190357/how-the-proxyaddresses-attribute-is-populated-in-az...

 

Personally, I wouldn’t rely on Azure AD updating synchronised accounts. Please manage the mail attribute using On-Prem AD to avoid ambiguity.

 

So how does this help me? :smiling_face_with_smiling_eyes:

 

Check one of your problematic users using the Graph API explorer, unless you connect to Exchange Online, mail attribute isn't exposed:

  1. Login to the graph api explorer - https://developer.microsoft.com/en-us/graph/graph-explorer#
  2. Paste the following query into the query window and add you users UPN
  3. https://graph.microsoft.com/v1.0/users/[UPNHere]AD.png
Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
9 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies