Home

Azure AD B2C - Claims in Sign up and sign in are not showing

%3CLINGO-SUB%20id%3D%22lingo-sub-918486%22%20slang%3D%22en-US%22%3EAzure%20AD%20B2C%20-%20Claims%20in%20Sign%20up%20and%20sign%20in%20are%20not%20showing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-918486%22%20slang%3D%22en-US%22%3E%3CP%3E%3CEM%3EI%20am%20missing%20something%20simple%20I%20am%20sure...%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20user%20flow%20created%20for%20Sign%20up%20and%20sign%20in%20as%20follow%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F138399i43F01C50A4677B02%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EI%20am%20interested%20in%20returning%20the%20following%20claims%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F138400i7B44717EE76FEA22%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_1.png%22%20title%3D%22clipboard_image_1.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20using%20the%20run%20user%20flow%20with%20the%20reply%20URL%20to%20view%20the%20JWT%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F138401i3EA3E86AFFCC517C%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_2.png%22%20title%3D%22clipboard_image_2.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20receiving%20a%20response%20with%20the%20claims%20I%20specified%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F138402i4D6603C4BBCE5DF5%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_3.png%22%20title%3D%22clipboard_image_3.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%2C%20is%20there%20a%20setting%20I%20am%20overlooking%20to%20ask%20Azure%20B2C%20to%20remove%20the%20claims%20I%20specified%20or%20to%20disable%20the%20default%20behavior%20or%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20pointers%20appreciated%20as%20I%20just%20cannot%20spot%20what%20I%20am%20doing%20wrong.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-918486%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20AD%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EIdentity%20Management%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Jeffrey Chilberto
Occasional Contributor

I am missing something simple I am sure...

 

I have a user flow created for Sign up and sign in as follow:

clipboard_image_0.png

I am interested in returning the following claims:

clipboard_image_1.png

 

When using the run user flow with the reply URL to view the JWT:

clipboard_image_2.png

 

I am receiving a response without the claims I specified:

clipboard_image_3.png

 

So, is there a setting I am overlooking to ask Azure B2C to add the claims I specified or to disable the default behavior or ?

 

Any pointers appreciated as I just cannot spot what I am doing wrong.

 

1 Reply

After trial and error, I believe the behavior is different than I was expecting. I had two boolean values defined in user attributes. These values were not added to the user attributes of the user flow but added to the application claims. My assumption was the values would be set to false in this case but they are not.

 

In short, it is as simple as if a claim does not have a value then it will not be returned. So a boolean claim will then have three possible values: true, false, missing.

 

I tested this with Postcode and it has the same behavior

Related Conversations
Tabs and Dark Mode
cjc2112 in Discussions on
35 Replies
Extentions Synchronization
Deleted in Discussions on
3 Replies
Security Community Webinars
Valon_Kolica in Security, Privacy & Compliance on
9 Replies
flashing a white screen while open new tab
Deleted in Discussions on
14 Replies